re = /\b(?<!\.)(?:\d[ -]*){5,10}\b/m
str = '12.123456 = no match
Hello John 124567 = match
12345667 = match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end