using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"P(ost)?[\.\s]*(O|0)(ff(ice)?)?[\.\s]+B(o|0)x";
string input = @"PO Box
P.O. Box
PO. Box
po box
P.o box
PoBox
p.o. Box
post office box 716
Post O. box
Post off box
p office box
p off BOX
p0 box
p0ffice box k";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}