import Foundation
let pattern = #"P(ost)?[\.\s]*(O|0)(ff(ice)?)?[\.\s]+B(o|0)x"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
PO Box
P.O. Box
PO. Box
po box
P.o box
PoBox
p.o. Box
post office box 716
Post O. box
Post off box
p office box
p off BOX
p0 box
p0ffice box k
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)