re = /P(ost)?[\.\s]*(O|0)(ff(ice)?)?[\.\s]+B(o|0)x/mi
str = 'PO Box
P.O. Box
PO. Box
po box
P.o box
PoBox
p.o. Box
post office box 716
Post O. box
Post off box
p office box
p off BOX
p0 box
p0ffice box k'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end