const regex = /(?:\b\d+[,.]|\B[.,])?\d+\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b\\d+[,.]|\\B[.,])?\\d+\\b', 'g')
const str = `.455 and ,445 44,5345 435.54 4444
1
1,2
1.5-4 (matches 1.5 & 4 separately)
(1+3) (matches 1 & 3 separately)
=1;
FF3D
3deg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}