re = /(?:\b\d+[,.]|\B[.,])?\d+\b/
str = '.455 and ,445 44,5345 435.54 4444
1
1,2
1.5-4 (matches 1.5 & 4 separately)
(1+3) (matches 1 & 3 separately)
=1;
FF3D
3deg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end