# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\b\d+[,.]|\B[.,])?\d+\b"
test_str = (".455 and ,445 44,5345 435.54 4444\n"
"1\n"
"1,2\n"
"1.5-4 (matches 1.5 & 4 separately)\n"
"(1+3) (matches 1 & 3 separately)\n"
"=1;\n\n"
"FF3D\n"
"3deg")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.