#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\D+[路|街|大道|村|队][--\d]+号)?(\D*)?(.+[幢|栋|号楼])?(.+单元)?([-\d]+室?)?$"
Local $sString = "万达茂e座B栋1513" & @CRLF & _
"马群街道馨康苑12号楼1单元1003室" & @CRLF & _
"南京栖霞区银城KINMA-Q+社区3栋902" & @CRLF & _
"和燕路438号城市绿洲花园11幢四单元208室" & @CRLF & _
"合班村省电宿舍14幢102室" & @CRLF & _
"学仕风华苑33栋503" & @CRLF & _
"华电三宿舍27幢215室" & @CRLF & _
"尧顺佳园2765栋2单元306" & @CRLF & _
"金马路16号6幢三单元401室" & @CRLF & _
"江苏南京市栖霞区尧林仙居青山苑17幢601室" & @CRLF & _
"仙境路29号50幢一单元302室" & @CRLF & _
"尧化门街道新城家园5幢2-603室" & @CRLF & _
"江苏南京市栖霞区宁杭公路2号百水芊城秀水坊6幢三单元106室" & @CRLF & _
"四季金辉8-3401" & @CRLF & _
"临江街64-1号" & @CRLF & _
"文澜路6号亚朵酒店"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")