import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\D+[路|街|大道|村|队][--\\d]+号)?(\\D*)?(.+[幢|栋|号楼])?(.+单元)?([-\\d]+室?)?$";
final String string = "万达茂e座B栋1513\n"
+ "马群街道馨康苑12号楼1单元1003室\n"
+ "南京栖霞区银城KINMA-Q+社区3栋902\n"
+ "和燕路438号城市绿洲花园11幢四单元208室\n"
+ "合班村省电宿舍14幢102室\n"
+ "学仕风华苑33栋503\n"
+ "华电三宿舍27幢215室\n"
+ "尧顺佳园2765栋2单元306\n"
+ "金马路16号6幢三单元401室\n"
+ "江苏南京市栖霞区尧林仙居青山苑17幢601室\n"
+ "仙境路29号50幢一单元302室\n"
+ "尧化门街道新城家园5幢2-603室\n"
+ "江苏南京市栖霞区宁杭公路2号百水芊城秀水坊6幢三单元106室\n"
+ "四季金辉8-3401\n"
+ "临江街64-1号\n"
+ "文澜路6号亚朵酒店";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}