use strict;
my $str = '万达茂e座B栋1513
马群街道馨康苑12号楼1单元1003室
南京栖霞区银城KINMA-Q+社区3栋902
和燕路438号城市绿洲花园11幢四单元208室
合班村省电宿舍14幢102室
学仕风华苑33栋503
华电三宿舍27幢215室
尧顺佳园2765栋2单元306
金马路16号6幢三单元401室
江苏南京市栖霞区尧林仙居青山苑17幢601室
仙境路29号50幢一单元302室
尧化门街道新城家园5幢2-603室
江苏南京市栖霞区宁杭公路2号百水芊城秀水坊6幢三单元106室
四季金辉8-3401
临江街64-1号
文澜路6号亚朵酒店';
my $regex = qr/^(\D+[路|街|大道|村|队][--\d]+号)?(\D*)?(.+[幢|栋|号楼])?(.+单元)?([-\d]+室?)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}