import re
regex = re.compile(r"\"-- starting hand \#(?P<handnum>\d+) \(id: (?P<handid>[a-z0-9]+)\) \((?P<gametype>.*?)\) \(dealer: \"\"(?P<buttonplayer>.*?)\"\"\) --\",(?P<handutc>.*?),(?P<handseqno>.*$)", flags=re.MULTILINE)
test_str = "\"-- starting hand #7 (id: tooolqqevl05) (No Limit Texas Hold'em) (dealer: \"\"michael @ VEYRadLj9o\"\") --\",2023-01-14T21:49:44.596Z,167373298459600"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")