re = /\"-- starting hand \#(?P<handnum>\d+) \(id: (?P<handid>[a-z0-9]+)\) \((?P<gametype>.*?)\) \(dealer: \"\"(?P<buttonplayer>.*?)\"\"\) --\",(?P<handutc>.*?),(?P<handseqno>.*$)/m
str = '"-- starting hand #7 (id: tooolqqevl05) (No Limit Texas Hold\'em) (dealer: ""michael @ VEYRadLj9o"") --",2023-01-14T21:49:44.596Z,167373298459600'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end