#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\s(?:/\s+XO[A-Z0-9\s]*\b|/)\s+(.+)"
Local $sString = "90.12.21 / 02.05 / XO3 File Name Type " & @CRLF & _
"10.22.43 / X.89 / XO20G9992 Document Internal Only" & @CRLF & _
"Phase 3" & @CRLF & _
"22.32.42.12 / 99.23 / XO2 Location Site 3: Park Triangle" & @CRLF & _
"38.23.99.22 / X.23 / XO28W9998 Block 4 Beach/Dock Camp" & @CRLF & _
"39.24.32.49 / 37.29 / Blue-print/Register Info Site (RISs)" & @CRLF & _
"23.21.53.32 / Q.21 / XO R9924 Location Place 5: Drive Place (Active)" & @CRLF & _
" 33.51.63.33 / X.21 / XO20W8812 Area Place 1: Beach Drive"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")