$re = '/.*\s(?:/\s+XO[A-Z0-9\s]*\b|/)\s+(.+)/m';
$str = '90.12.21 / 02.05 / XO3 File Name Type
10.22.43 / X.89 / XO20G9992 Document Internal Only
Phase 3
22.32.42.12 / 99.23 / XO2 Location Site 3: Park Triangle
38.23.99.22 / X.23 / XO28W9998 Block 4 Beach/Dock Camp
39.24.32.49 / 37.29 / Blue-print/Register Info Site (RISs)
23.21.53.32 / Q.21 / XO R9924 Location Place 5: Drive Place (Active)
33.51.63.33 / X.21 / XO20W8812 Area Place 1: Beach Drive';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);