import re
regex = re.compile(r".*\s(?:/\s+XO[A-Z0-9\s]*\b|/)\s+(.+)", flags=re.MULTILINE)
test_str = ("90.12.21 / 02.05 / XO3 File Name Type \n"
"10.22.43 / X.89 / XO20G9992 Document Internal Only\n"
"Phase 3\n"
"22.32.42.12 / 99.23 / XO2 Location Site 3: Park Triangle\n"
"38.23.99.22 / X.23 / XO28W9998 Block 4 Beach/Dock Camp\n"
"39.24.32.49 / 37.29 / Blue-print/Register Info Site (RISs)\n"
"23.21.53.32 / Q.21 / XO R9924 Location Place 5: Drive Place (Active)\n"
" 33.51.63.33 / X.21 / XO20W8812 Area Place 1: Beach Drive")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")