const regex = /(\w{3})[-_~\s*\.]*?(\d{1,}|\d*.\d*.\d*)[-_\s.~]*?(FTP|IMG|SCR|LIV|TVU).?-?\s?(\w{3}).\s?-?_?~?\.?(\d*).\s?-?~?_?\.?(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w{3})[-_~\\s*\\.]*?(\\d{1,}|\\d*.\\d*.\\d*)[-_\\s.~]*?(FTP|IMG|SCR|LIV|TVU).?-?\\s?(\\w{3}).\\s?-?_?~?\\.?(\\d*).\\s?-?~?_?\\.?(.*)', 'gm')
const str = `NWS_20-12-19_FTP_VLR_01_This is a test message
NWS 11219 LIV TNL 02 Second test message
NWS~11/12/2019~IMG-KNK-4-third_test_message
NWS-12-12-19-SCR-TVM-03-Fourth-test-message
NWS - 12.12.2019 - FTP - CGP -5 - fifth test message
NWS_12.12/19~FTP-CHN 01_sixth test message `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}