// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w{3})[-_~\s*\.]*?(\d{1,}|\d*.\d*.\d*)[-_\s.~]*?(FTP|IMG|SCR|LIV|TVU).?-?\s?(\w{3}).\s?-?_?~?\.?(\d*).\s?-?~?_?\.?(.*)").unwrap();
let string = "NWS_20-12-19_FTP_VLR_01_This is a test message
NWS 11219 LIV TNL 02 Second test message
NWS~11/12/2019~IMG-KNK-4-third_test_message
NWS-12-12-19-SCR-TVM-03-Fourth-test-message
NWS - 12.12.2019 - FTP - CGP -5 - fifth test message
NWS_12.12/19~FTP-CHN 01_sixth test message ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}