# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\w{3})[-_~\s*\.]*?(\d{1,}|\d*.\d*.\d*)[-_\s.~]*?(FTP|IMG|SCR|LIV|TVU).?-?\s?(\w{3}).\s?-?_?~?\.?(\d*).\s?-?~?_?\.?(.*)"
test_str = ("NWS_20-12-19_FTP_VLR_01_This is a test message\n"
"NWS 11219 LIV TNL 02 Second test message\n"
"NWS~11/12/2019~IMG-KNK-4-third_test_message\n"
"NWS-12-12-19-SCR-TVM-03-Fourth-test-message\n"
"NWS - 12.12.2019 - FTP - CGP -5 - fifth test message\n"
"NWS_12.12/19~FTP-CHN 01_sixth test message ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.