import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([12]|44).*";
final String string = "1071922746\n"
+ "1471922746\n"
+ "1671922746\n"
+ "2071922746\n"
+ "2471922746\n"
+ "2671922746\n"
+ "3071922746\n"
+ "4071922746\n"
+ "4471922746\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}