const regex = /^([12]|44).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([12]|44).*', 'gm')
const str = `1071922746
1471922746
1671922746
2071922746
2471922746
2671922746
3071922746
4071922746
4471922746
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}