$re = '/^([12]|44).*/m';
$str = '1071922746
1471922746
1671922746
2071922746
2471922746
2671922746
3071922746
4071922746
4471922746
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);