package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?|(?P<ALL>.*(?P<ID>\bH-\d{4}\b).*)|(?P<ALL>.+))`)
var str = `Sample line with H-5722 id
Sample line without id`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}