re = /(?|(?P<ALL>.*(?P<ID>\bH-\d{4}\b).*)|(?P<ALL>.+))/
str = 'Sample line with H-5722 id
Sample line without id'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end