using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(ABCDE\_1234\>|ABCDE\_)";
string input = @"Как получить ""ABCDE_1234>"" если есть "">""
Как получить ""ABCDE_12345>"" если есть "">"" ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}