package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ABCDE\_1234\>|ABCDE\_)`)
var str = `Как получить "ABCDE_1234>" если есть ">"
Как получить "ABCDE_12345>" если есть ">" `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}