// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(ABCDE\_1234\>|ABCDE\_)").unwrap();
let string = "Как получить \"ABCDE_1234>\" если е сть \">\"
Как получить \"ABCDE_12345>\" если есть \">\" ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}