import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Print #\\w+, (?:[^;\\r\\n]+;?)+";
final String string = "Print #FileNo, Tab(1); \"My Text Here\";\n\n"
+ "Print #FileNo, Tab(col); Txt;\n\n"
+ "Print #FileNo, Tab(100); Format(TheDate, \"DDMMMYYYY\") & \" \" & Variable_Name & \"Field : \" & Format(Field, \"x\")\n\n"
+ "Print #FileNo, Tab(1); Format(TheDate, \"x\") & \" - \" & TheName;\n\n"
+ "Print #FileNo, String(132, \"-\")\n\n"
+ "Print #FileNo, Tab(6); \"SOME VALUE\";\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}