// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Print #\w+, (?:[^;\r\n]+;?)+").unwrap();
let string = "Print #FileNo, Tab(1); \"My Text Here\";
Print #FileNo, Tab(col); Txt;
Print #FileNo, Tab(100); Format(TheDate, \"DDMMMYYYY\") & \" \" & Variable_Name & \"Field : \" & Format(Field, \"x\")
Print #FileNo, Tab(1); Format(TheDate, \"x\") & \" - \" & TheName;
Print #FileNo, String(132, \"-\")
Print #FileNo, Tab(6); \"SOME VALUE\";
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}