import re
regex = re.compile(r"Print #\w+, (?:[^;\r\n]+;?)+", flags=re.MULTILINE)
test_str = ("Print #FileNo, Tab(1); \"My Text Here\";\n\n"
"Print #FileNo, Tab(col); Txt;\n\n"
"Print #FileNo, Tab(100); Format(TheDate, \"DDMMMYYYY\") & \" \" & Variable_Name & \"Field : \" & Format(Field, \"x\")\n\n"
"Print #FileNo, Tab(1); Format(TheDate, \"x\") & \" - \" & TheName;\n\n"
"Print #FileNo, String(132, \"-\")\n\n"
"Print #FileNo, Tab(6); \"SOME VALUE\";\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")