package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s*([^,\s]+\s*)+$`)
var str = `
dd,ff
ab c!@#)(*&^%$#~
sfsfsf,sdfsdf
abc xyz `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}