$re = '/^\s*([^,\s]+\s*)+$/m';
$str = '
dd,ff
ab c!@#)(*&^%$#~
sfsfsf,sdfsdf
abc xyz ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);