re = /^\s*([^,\s]+\s*)+$/m
str = '
dd,ff
ab c!@#)(*&^%$#~
sfsfsf,sdfsdf
abc xyz '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end