using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\"")\b[a-z_]+\b(?!\"")";
string input = @"results[0].items[0].packages[0].settings[""compiler.version""]
results[0].items[0].packages[0].settings.build_type";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}