$re = '/(?<!\")\b[a-z_]+\b(?!\")/m';
$str = 'results[0].items[0].packages[0].settings["compiler.version"]
results[0].items[0].packages[0].settings.build_type';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);