re = /(?<!\")\b[a-z_]+\b(?!\")/m
str = 'results[0].items[0].packages[0].settings["compiler.version"]
results[0].items[0].packages[0].settings.build_type'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end