package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Process\s+explanation\s*:\s*(.*?)(\.\s*Final activity|$)`)
var str = `Process explanation: plasma gasification combined with centrifugal activity. Final activity for manager: some activity`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}