$re = '/Process\s+explanation\s*:\s*(.*?)(\.\s*Final activity|$)/m';
$str = 'Process explanation: plasma gasification combined with centrifugal activity. Final activity for manager: some activity';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);