const regex = /Process\s+explanation\s*:\s*(.*?)(\.\s*Final activity|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Process\\s+explanation\\s*:\\s*(.*?)(\\.\\s*Final activity|$)', 'gm')
const str = `Process explanation: plasma gasification combined with centrifugal activity. Final activity for manager: some activity`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}