using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(\(.*\))?$";
string substitution = @"\1";
string input = @"DECIMAL
DECIMAL(14,5)
RAND(1)
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}