using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+\s(\w+\s)+\w\.\s\w+$";
string input = @"Tim Biegeleisen
Francis Scott Key
Francis Francis S. Key
John John John J. Johnny";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}