re = /^\w+\s(\w+\s)+\w\.\s\w+$/m
str = 'Tim Biegeleisen
Francis Scott Key
Francis Francis S. Key
John John John J. Johnny'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end