$re = '/^\w+\s(\w+\s)+\w\.\s\w+$/m';
$str = 'Tim Biegeleisen
Francis Scott Key
Francis Francis S. Key
John John John J. Johnny';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);