import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\S+) - (.*)";
final String string = "phantasmagoria - A long an intricate explanation. With a random dask, -, in it\n"
+ "rake - dated a fashionable...\n"
+ "roué - a debauched man...\n"
+ "word - another - Something?\n"
+ "This is another test - of that regex. Should this be picked up?\n"
+ "And what about $ 5 - 3 = 2$, is an example of elementary math.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}