re = /^(\S+) - (.*)/m
str = 'phantasmagoria - A long an intricate explanation. With a random dask, -, in it
rake - dated a fashionable...
roué - a debauched man...
word - another - Something?
This is another test - of that regex. Should this be picked up?
And what about $ 5 - 3 = 2$, is an example of elementary math.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end