const regex = /^(\S+) - (.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S+) - (.*)', 'gm')
const str = `phantasmagoria - A long an intricate explanation. With a random dask, -, in it
rake - dated a fashionable...
roué - a debauched man...
word - another - Something?
This is another test - of that regex. Should this be picked up?
And what about \$ 5 - 3 = 2\$, is an example of elementary math.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}