#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^.\n]*[^\/\n]*\.\K[^\/\n]+"
Local $sString = "https://www.example.org/" & @CRLF & _
"http://example.com/" & @CRLF & _
"ca.gov" & @CRLF & _
"http://blade.example.com/bikes/airplane.php" & @CRLF & _
"http://alarm.example.com/" & @CRLF & _
"smugmug.com" & @CRLF & _
"shop-pro.jp" & @CRLF & _
"https://example.org/" & @CRLF & _
"qq.com" & @CRLF & _
"pcworld.com" & @CRLF & _
"symantec.com" & @CRLF & _
"360.cn" & @CRLF & _
"http://example.com/?brother=bike" & @CRLF & _
"http://www.example.com/behavior/bead.php" & @CRLF & _
"army.mil" & @CRLF & _
"https://example.com/boy/bedroom.php" & @CRLF & _
"https://example.com/" & @CRLF & _
"https://www.example.com/brother?activity=believe" & @CRLF & _
"https://www.example.net/achiever/bottle.html" & @CRLF & _
"http://believe.example.com/bit?bait=base&bone=ball" & @CRLF & _
"aboutads.info" & @CRLF & _
"http://www.example.com/" & @CRLF & _
"http://www.example.edu/afternoon" & @CRLF & _
"livejournal.com" & @CRLF & _
"http://border.example.com/box/afterthought" & @CRLF & _
"oaic.gov.au" & @CRLF & _
"https://www.example.edu/base.php" & @CRLF & _
"house.gov" & @CRLF & _
"smh.com.au" & @CRLF & _
"http://www.example.edu/" & @CRLF & _
"https://www.example.org/" & @CRLF & _
"lycos.com" & @CRLF & _
"https://border.example.com/?bridge=basket&blood=animal" & @CRLF & _
"hibu.com" & @CRLF & _
"http://example.com/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")