# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^.\n]*[^\/\n]*\.\K[^\/\n]+"
test_str = ("https://www.example.org/\n"
"http://example.com/\n"
"ca.gov\n"
"http://blade.example.com/bikes/airplane.php\n"
"http://alarm.example.com/\n"
"smugmug.com\n"
"shop-pro.jp\n"
"https://example.org/\n"
"qq.com\n"
"pcworld.com\n"
"symantec.com\n"
"360.cn\n"
"http://example.com/?brother=bike\n"
"http://www.example.com/behavior/bead.php\n"
"army.mil\n"
"https://example.com/boy/bedroom.php\n"
"https://example.com/\n"
"https://www.example.com/brother?activity=believe\n"
"https://www.example.net/achiever/bottle.html\n"
"http://believe.example.com/bit?bait=base&bone=ball\n"
"aboutads.info\n"
"http://www.example.com/\n"
"http://www.example.edu/afternoon\n"
"livejournal.com\n"
"http://border.example.com/box/afterthought\n"
"oaic.gov.au\n"
"https://www.example.edu/base.php\n"
"house.gov\n"
"smh.com.au\n"
"http://www.example.edu/\n"
"https://www.example.org/\n"
"lycos.com\n"
"https://border.example.com/?bridge=basket&blood=animal\n"
"hibu.com\n"
"http://example.com/")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.