package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+\) [A-Za-z+ ]+)`)
var str = `1) this is an example 2) another 15) still another`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}