$re = '/(\d+\) [A-Za-z+ ]+)/';
$str = '1) this is an example 2) another 15) still another';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);