package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(0+\.[0-9]?e?[+-]?[0-9]+)\s+([0-9]+\.?[0-9]*|[0-9][0-9]?[0-9]?[A-Z][a-z]?)\s+([0-9][0-9]?[0-9]?)\s+(\[.*\])\s+(\[.*\])$`)
var str = `0.625846 29Si 29 [4934.39 0] [0.84 100000000000000.0]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}